Eigenes VPN-Darknetz

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

      Eigenes VPN-Darknetz

      Hallo zusammen,



      wir haben in der Firma (Standort 1)mehre DSL Businessanschlüsse und einen Glasfaser Business Breitband Anschluss, also alle mit einer Festen IP.

      Dazu haben wir mehre Standort (Standort 2-3), die
      alle einen eigenen Business Breitband Anschluss haben. Zwischen einigen
      standortorten haben wir eine LWL Singlemode Verbindung und via RJ45
      Media Convertern und uns ein Netzwerk aufgebaut.



      Nun wollte ich gerne vom Standort 1 auf den Standort 2-3 zugreifen bzw. ein VPN herstellen. Wir haben am Standort 2-3 einen
      Cisco Router RV325 mit einer Festen IP. In der Firma habe ich eine
      Fritzbox 7270 aktuell aber könnte auch eine 7390 an den freien DSL
      Anschluss anschließen.



      Könnte ich damit eine VPN Verbindung aufbauen oder brauche ich da was anderes?





      Gruß Gifti
      Aktuelle Baustelle: Dell Inspiron 15, 7570, i7-8550U, 8GB DDR4, SSD 240GB, OSX 10.12.6, MacBookPro 14.3, CLOVER r4558
      System 1 Gigabyte Z77-DS3H, F11a Ozmosis Rev 1.1, i7-2600K, GT710, 8GB DDR3, 240GB SSD, OS 10.10.2, Wlan: TP-Link WN881ND

      System 2 Asus P8Z77-M, i7-3770, 10GB DDR3-1333, 240GB SSD, OS 10.12.6, iMac 14.2, Ozmosis
      System 3 Gigabyte H55M-USB3, F11, i5-750, AMD HD5770 1GB, 8GB DDR3, 80GB SSD, OS 10.10.2, Belkin Wlan: F7D2101v1

      System 4 Gigabyte EP45-DS3L, F11c Rev 1.0, Intel Q8400, Asus HD5450, 5GB DDR2, 160GB HDD, OS 10.9.1, DSDT
      System 5 Dell Latitude E6420, i5-2520M, HD3000, 6GB DDR3, 128GB SSD, 10.12.5, Wlan: Dell DW1520, DSDT + Kexte, r4061
      Hi, also du möchtest einen VPN-Tunnel vom Standort 2-3 zu Standort 1 haben.???
      Dann mußt du am Standort 2-3 einen VPN-Server laufen lassen. Dazu würde sich eine FritzBox 7362, o. ä. eignen. Sicherlich auch ein anderer Routertyp. Wenn der VPN-Server installiert ist und läuft, kannst du mit deinem MAC eine VPN-Verbindung vom Standort1 zum VPN-Server (Router Standort 2-3) aufbauen. Ist der Tunnel geschaltet, kannst du auf alle NetzFreigaben des Standort 2-3 vom Standort 1 aus, zugreifen.
      Am MAC kannst den VPN-Client in der Systemsteuerung/Netzwerk einrichten und konfigurieren. Ich selbst nutze so einen VPN-Tunnel zu mir nach Hause. In meinem Heimnetz läuft eine 7362SL. Greife von unterwegs aus auf alle Netzwerkfreigaben des Heimnetzwerks zu. Mit ElCapitan soll es aber Probleme mit dem VPN-Client geben. Habe es noch nicht probiert. Bei mir läuft noch 10.9.5. auf dem MAC mit dem VPN-Client.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Eigenes VPN-Darknetz

      Hallo McLane,

      Danke für deine Tipps.
      Ich habe auch noch eine 7362SL von 1&1 hier liegen. Wie installiert man da einen VPN Server drauf oder kann man das aktivieren im Setup?

      Gruß Gifti

      PS: ich bevorzuge es, vom Standort 1 den VPN Server zu haben, da ich dort auch immer bin.


      Gesendet von iPhone mit Tapatalk
      Aktuelle Baustelle: Dell Inspiron 15, 7570, i7-8550U, 8GB DDR4, SSD 240GB, OSX 10.12.6, MacBookPro 14.3, CLOVER r4558
      System 1 Gigabyte Z77-DS3H, F11a Ozmosis Rev 1.1, i7-2600K, GT710, 8GB DDR3, 240GB SSD, OS 10.10.2, Wlan: TP-Link WN881ND

      System 2 Asus P8Z77-M, i7-3770, 10GB DDR3-1333, 240GB SSD, OS 10.12.6, iMac 14.2, Ozmosis
      System 3 Gigabyte H55M-USB3, F11, i5-750, AMD HD5770 1GB, 8GB DDR3, 80GB SSD, OS 10.10.2, Belkin Wlan: F7D2101v1

      System 4 Gigabyte EP45-DS3L, F11c Rev 1.0, Intel Q8400, Asus HD5450, 5GB DDR2, 160GB HDD, OS 10.9.1, DSDT
      System 5 Dell Latitude E6420, i5-2520M, HD3000, 6GB DDR3, 128GB SSD, 10.12.5, Wlan: Dell DW1520, DSDT + Kexte, r4061
      Tu dir selbst den gefallen und mach ein solches konstrukt per IPsec:

      Standort 1 -> Standort 2
      Standort 1 -> Standort 3
      Standort 2 -> Standort 3

      inklusive routing, sonst kann ich dir jetzt schon sagen, dass du keinen spaß damit haben wirst die Fehler zu beheben.

      Bei uns in der Firma ist das konstrukt so per IPsec:
      Standort 1 -> Standort 2
      Standort 1 -> Standort 3
      Standort 1 -> Standort 4
      Standort 1 -> Standort 5
      Standort 2 -> Standort 3
      Standort 2 -> Standort 4
      Standort 2 -> Standort 5
      Standort 3 -> Standort 4
      Standort 3 -> Standort 5
      Standort 4 -> Standort 5

      Ist zwar mehr arbeit, aber ansonsten hast du nachher nur noch probleme was Routing angeht.
      Show Spoiler

      iMac 2007 3,0Ghz Core 2 Duo
      @Gifti:

      Wenn Du am Standort 1 bist, müssen die VPN-Server am Standort 2 und am Standort 3 eingerichtet werden. Der Standort 1 braucht den VPN-Client.

      Wenn du die VPN-Server mit FritzBoxen einrichten möchtest, gehe dazu auf die AVM-Seite. Dort ist eine detailierte Anleitung vorhanden.

      Guckst du hiere: Links are hidden, please login in or register.

      Falls es Probleme mit dem hausinternen VPN-Client von ElCapitan gibt, kannst du den von Shrew-Soft probieren.
      Die Anleitung für die Einrichtung des Shrew-VPNCLienten befindet sich im InstallPaket des WIN-Clienten auf der Downloadseite von ShrewSoft.

      VPN-Client-Software für MAC: Links are hidden, please login in or register.



      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 4 times, last by “McLane” ().

      Hallo ihr zwei, vielen dank für eure unterstützung!

      Ich habe heute den ganzen tag probiert und bin soweit, dass ich auf einer Fritzbox VPN mit MyFritz eingerichtet.

      Dann habe ich auf einen Rechner in der Firma, SHREW SOFT VPN CLIENT installiert und alles soweit eingetragen.
      Auf der Fritzbox wird dann angezeigt: Fernzugang (VPN) wird aufgebaut, XXXX
      Leider passiert mehr nicht. Auch auf einen anderen Rechner, außerhalb von unseren Firmen-Netzwerk klappt es nicht.

      Nun habe ich überlegt, das ganze andersrum aufzubauen.
      Also am Standort 2 ist der Cisco RV325 und dieser hat auch eine öffentliche IP. Außerdem kann der 50 Virtuelle VPN´s erstellen und 2 WAN ausgänge und ich könnte noch eine 2 feste Öffentliche IP einrichten.

      Nun ist die frage, welche Hardware wäre an Standort 1, 3 und 4 notwendig, aus eure sicht?
      Aktuelle Baustelle: Dell Inspiron 15, 7570, i7-8550U, 8GB DDR4, SSD 240GB, OSX 10.12.6, MacBookPro 14.3, CLOVER r4558
      System 1 Gigabyte Z77-DS3H, F11a Ozmosis Rev 1.1, i7-2600K, GT710, 8GB DDR3, 240GB SSD, OS 10.10.2, Wlan: TP-Link WN881ND

      System 2 Asus P8Z77-M, i7-3770, 10GB DDR3-1333, 240GB SSD, OS 10.12.6, iMac 14.2, Ozmosis
      System 3 Gigabyte H55M-USB3, F11, i5-750, AMD HD5770 1GB, 8GB DDR3, 80GB SSD, OS 10.10.2, Belkin Wlan: F7D2101v1

      System 4 Gigabyte EP45-DS3L, F11c Rev 1.0, Intel Q8400, Asus HD5450, 5GB DDR2, 160GB HDD, OS 10.9.1, DSDT
      System 5 Dell Latitude E6420, i5-2520M, HD3000, 6GB DDR3, 128GB SSD, 10.12.5, Wlan: Dell DW1520, DSDT + Kexte, r4061
      Es gibt bei VPN-Verbindungen noch eine große Stolperfalle:
      Die Netzwerke an den Standorten MüSSEN UNTERSCHIEDLICHE Netzwerkbereiche haben. Dazu Beispiele:
      STO1: 192.168.1.abc STO2: 192.168.5.abc geht
      STO1: 192.168.1.abc STO2: 192.168.1.abc GEHT NICHT!!!!
      Vielleicht liegt auch hier der Fehler bei dir.
      Übrigens: Die Anleitung für Shrew-Client ist im Installationspaket verpackt, auch mit entsprechenden Bildern für die Reiterkarten des ShrewVPN-Client. Die mußt GENAU befolgen.
      -> MyFritz oder ein anderes DynDNS-Konto brauchst du nur, wenn sich deine IP-Adresse jeden Tag ändert.
      Hast du eine feste IP-Adresse, brauchst du also keines von diesen Konten.

      Links are hidden, please login in or register. Link zur Anleitung

      Die Eintragung müssen genauso gemacht werden, wie in der Anleitung zu sehen ist! Gilt für WIN UND für MAC!
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 1 time, last by “McLane” ().

      Moin zusammen,

      Also mit Shrew-Client VPN bekomme ich ein VPN tunnel zum laufen (Windows 7 Rechner mit Fritzbox 7362SL).
      Sobald der Tunnel steht, bekomme ich auch die neue IP wenn ich Links are hidden, please login in or register. anwähle.
      Aber ich kann nicht auf geräte (PC´s) im netzwerk zugreifen. Als IP bekomme ich dann 192.168.100.252
      Wo liegt da mein fehler, bzw. habt ihr noch eine Idee?

      Bei einer VPN Verbindung Fritzbox-Lan zu Fritzbox Lan, kann ich machen was ich will. Es kommt keine Verbindung zustande.
      Meine Config:
      STO1: 192.168.100.1 (DHCP 192.168.100.100-250)
      STO2: 192.168.200.1 (DHCP 192.168.200.100-250)
      In der Config gebe ich als Entferntes Netzwerk immer 192.168.100.0 bzw. 192.168.200.0 an (laut Fritzbox Anleitung).
      Ich habe hier feste IP´s. aber selbst mit den Fritzbox DNS Acc´s klappt es nicht.
      Aktuelle Baustelle: Dell Inspiron 15, 7570, i7-8550U, 8GB DDR4, SSD 240GB, OSX 10.12.6, MacBookPro 14.3, CLOVER r4558
      System 1 Gigabyte Z77-DS3H, F11a Ozmosis Rev 1.1, i7-2600K, GT710, 8GB DDR3, 240GB SSD, OS 10.10.2, Wlan: TP-Link WN881ND

      System 2 Asus P8Z77-M, i7-3770, 10GB DDR3-1333, 240GB SSD, OS 10.12.6, iMac 14.2, Ozmosis
      System 3 Gigabyte H55M-USB3, F11, i5-750, AMD HD5770 1GB, 8GB DDR3, 80GB SSD, OS 10.10.2, Belkin Wlan: F7D2101v1

      System 4 Gigabyte EP45-DS3L, F11c Rev 1.0, Intel Q8400, Asus HD5450, 5GB DDR2, 160GB HDD, OS 10.9.1, DSDT
      System 5 Dell Latitude E6420, i5-2520M, HD3000, 6GB DDR3, 128GB SSD, 10.12.5, Wlan: Dell DW1520, DSDT + Kexte, r4061
      Habe auf diesem Thread hin mal ein paar Tests gemacht.
      Voraussetzung ist meine Hardware in der Signatur, also das GA-Board.
      Mit 10.9.5 und mit 10.10.5 bekomme ich den Tunnel mittels Boardmitel vom OS (IPSEC-CISCO-VPN) aufgebaut. Dann kann ich die SMB-Freigaben des angewählten Netzwerkes sehen, mappen und damit wunderbar arbeiten. Sogar RemoteDesktop geht wunderbar. Das gleiche Szenario mit 10.11.4 ----> Tunnel wird zwar aufgebaut, aber es erfolgt kein Netzwerkverkehr. Nach einer Weile bricht auch der Tunnel wieder zusammen. Der Rechner mit ElCapitan muß neu gestartet werden. Erst dann habe ich wieder NORMALEN Netzwerkzugang. Denn nachdem der VPN-Tunnel zusammengebrochen ist, geht auch die normale Netzwerkverbindung nicht mehr.
      Liegt es tatsächlich am 10.11.x ????
      Mein nächster Versuch wird eine VPN-Verbindung zu meiner Fritz.Box mit einem Orig.MAC und 10.11.4 sein.
      Werde hier weiter berichten.
      #########


      Also :( Versuchsreihe ausgeführt::::
      Den VPN-Tunnel kann man mit einem Orig-Mac aufbauen und auch prima nutzen. ABER: Warum geht es denn in einem Hacki nicht ??? Ist mir unbegreiflich. Die normalen Netzwerkaktivitäten funktionieren doch auch. Surfen,E-Mail geht super. Aber ein VPN Netzwerk aufbauen mit Boardmitteln oder auch mit der Shrew-Software gehen nicht. Der Tunnel wird aufgebaut, steht etwa eine Minuten und bricht dann zusammen. Der normale Netzwerkverkehr geht auch nicht mehr.... Man muß also neu booten. Komisch.

      --> Werde weiter forschen........
      Werde ein anderes Board mit EC befeuern und dann mal ausprobieren...

      Falls jemand noch einen Tip hat, wäre ich sehr dankbar.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 1 time, last by “McLane” ().

      Vermute der Kext für dein Lan ist das Problem. LAN aus und Wlan/BT Karte rein und die native Kext für Wlan/ BT Adapterkarten beheben diese Sorgen.
       iMac13,2  Im PowerMac G5 Wakü●Gigabyte GA Z77-DS3H●i7 3770K @4,3GHz●16 GB DDR3-1866●EVGA GTX 1070●
      WIFI+BT BCM94360CD PCI-E Card●Samsung 500GB SSD Evo 840
       MacBookPro10.1  Lenovo G500 i5 3230m●2x4 GiByte DDR3●SSD 120●WIFI BCM94312MCG
       MacBookAir5,2  Lenovo G500 i5-3320m●4 GiByte DDR3●SSD 240●WIFI+BT BCM94352HMB

      Danke für deinen Tip, Schorse.
      - Habe auf einem TECRA-Notebook, 10.11.3 in einer VM laufen. Bei der Installation brauchte ich keine Kexte nachinstallieren. Das Fehlerbild ist das gleiche!
      Werde am WE meinen Testschlauberger mit EC befeuern. Das ist ein ASROCK Z68 Pro3 Board und hat einen anderen LAN-Chip.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 1 time, last by “McLane” ().

      VPN´s auf VM? Welche Software setzt du ein? Beispiel: VMWare Fusion macht mir da einen Strich durch die Rechnung, dabei wird ja auch nicht wirklich ein Tunnel gebildet. Die VPN/Tunnel muss somit auf dem Hauptsystem laufen und wird dann via Internet-Sharing freigegeben.
      Wichtig! Deaktiviere Ipv6!
       iMac13,2  Im PowerMac G5 Wakü●Gigabyte GA Z77-DS3H●i7 3770K @4,3GHz●16 GB DDR3-1866●EVGA GTX 1070●
      WIFI+BT BCM94360CD PCI-E Card●Samsung 500GB SSD Evo 840
       MacBookPro10.1  Lenovo G500 i5 3230m●2x4 GiByte DDR3●SSD 120●WIFI BCM94312MCG
       MacBookAir5,2  Lenovo G500 i5-3320m●4 GiByte DDR3●SSD 240●WIFI+BT BCM94352HMB

      Hi Schorse, ich nutze VMWare-Workstation12 auf dem TECRA. Ok. Abgehakt.
      *****
      Habe mittlerweile auf dem ASROCK-Z68 eine frische Installation gemacht. Dann noch den LAN-Kext fürn RTL8111 mit Kext-Utility installiert-----UND funzt tatsächlich!
      Nun brauche ich noch einen Kext fürs GA-z77ds3h Board.

      *******
      Dieser Kext baut zwar das normale Netzwerk auf, aber VPN funzt eben nicht...-> Links are hidden, please login in or register.

      *******
      Links are hidden, please login in or register., was meinst du damit ?? > "LAN aus und Wlan/BT Karte rein und die native Kext für Wlan/ BT Adapterkarten beheben diese Sorgen."
      Soll ich mir eine PCI-Karte versorgen und sie einbauen ????
      Wer ist der Hersteller und wie heist sie??

      *******
      Habe einen Keks (s. Anhang) gefunden, welcher bis jetzt auf einer Maschine 10.11.4 funzt. VPN wird schnell aufgebaut, bleibt auch über längere Zeit stabil. Und die SMBFreigaben vom Zielnetz sind verfügbar. Teste das Ganze noch ein paar Tage, auch auf noch anderen Maschinen (mit dem gleichen Board!!).
      Files
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 3 times, last by “McLane” ().

      Also wenn ich diesen VPN aufbau sehe ... Urgh :dash:
      MacBook Pro late 2010
      Intel Core i7@2,66GHz
      GeForce GT 330M
      8GB DDR3-1600MHz
      480GB SSD

      Hackintosh Pro
      Intel Core Xeon E5-1620 0@3,7GHz
      GeForce GTX 760 4GB VRAM
      128GB DDR3-1600 MHz ECC R-DIMM
      3x 10TB Seagate Ironwolf RAID 5
      2x 275GB SSD
      Windows 10 Pro x64 Build 1803 UEFI
      macOS 10.13.4 Clover v2.4_r4449 UEFI

      "Urrgh" ist ein ausdruck .. keine tiefere Bedeutung ... Links are hidden, please login in or register. Hat schon recht mit IPSec arbeiten wir in der Firma auch ohne Probleme von Standort 1 bis 10 sind alle untereinander per IPSec verbunden .. das einzige "-" daran ist das es nicht mehr auf der höhe der zeit ist und daher ziemlich unsicher ist
      MacBook Pro late 2010
      Intel Core i7@2,66GHz
      GeForce GT 330M
      8GB DDR3-1600MHz
      480GB SSD

      Hackintosh Pro
      Intel Core Xeon E5-1620 0@3,7GHz
      GeForce GTX 760 4GB VRAM
      128GB DDR3-1600 MHz ECC R-DIMM
      3x 10TB Seagate Ironwolf RAID 5
      2x 275GB SSD
      Windows 10 Pro x64 Build 1803 UEFI
      macOS 10.13.4 Clover v2.4_r4449 UEFI

      WAS ist heute noch SICHER ?????

      #######

      Alle VPN-Clienten mit diesem Kext funzen bis jetzt Prima.
      AtherosL1cEthernet-1.2.3.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover; 10.14.5 GraKa ATI HD7850

      In Zweifelsfällen bin ich immer :dafuer: , dass wir :dagegen: sind. :omg:

      Post was edited 1 time, last by “McLane” ().

      Links are hidden, please login in or register.
      Ich gehe da einen anderen Weg, eventuell ist da ja etwas für dich als Anregung dabei.
      Beispiel:
      1: NAS mit VPN nach draußen und gültigen Zertifikat.
      2: Zugriff mit Client nur mit VPN, Zertifikat UND 2 Konten Verifizierung, Code wird sekundengenau von Google generiert.
      3: Zugriffe auf der NAS entsprechend vergeben.

      Vorteil, "fast" alles ist möglich und der Zugriff mit iOs klappt auch.

      Die Lösung mit der Fritzbox holpert da denke ich etwas, da diese Lösung als Einbahnstraße gedacht ist, mehrere Zugänge und unterschiedlich Zugriffe packt die von der Leistung auch nicht.

      Mal so als Frage, was soll den primär über die VPN verschoben werden?

      Links are hidden, please login in or register., sorry hatte wenig Zeit.
      Ich kann nur von Yosemite und VMWare Fusion berichten. Zumindest habe ich einer VM so ein 100% VPN beigebracht.
      Was ist schon sicher ist ja eigentlich der Ansatz in diesem Beitrag, oder?
      Hardware wie diese als Beispiel, sogar hier im Forum:
      Links are hidden, please login in or register.
       iMac13,2  Im PowerMac G5 Wakü●Gigabyte GA Z77-DS3H●i7 3770K @4,3GHz●16 GB DDR3-1866●EVGA GTX 1070●
      WIFI+BT BCM94360CD PCI-E Card●Samsung 500GB SSD Evo 840
       MacBookPro10.1  Lenovo G500 i5 3230m●2x4 GiByte DDR3●SSD 120●WIFI BCM94312MCG
       MacBookAir5,2  Lenovo G500 i5-3320m●4 GiByte DDR3●SSD 240●WIFI+BT BCM94352HMB

      Post was edited 2 times, last by “Schorse” ().