Probleme mit Audio - Realtek ALC 889 / 898 (?)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

      Probleme mit Audio - Realtek ALC 889 / 898 (?)

      Hallo Leute,

      ich habe mir macOS Sierra und den Bootloader Clover als UEFI auf meinem Notebook eingerichtet. Es funktioniert bisher ganz gut.

      Nun ich habe ein riesiges Problem mit der Audiokarte. Laut DCPIManager zeigt er mir eine Realtek ALC 898 an und als Codec ID aber eine 889 an. Ich habe versucht mittels CloverALC.sh die Einrichtung vorzunehmen. Er erkennt die Karte auch als ALC 898 und Inject ID 1.

      Wenn ich das installiert habe und neu starte, ist die Audiokarte vorhanden und man kann auch die Anschlüsse im Manager sehen, aber es kommt einfach kein Sound aus der Kiste.

      In Clover habe ich FixHDA gesetzt, damit mein System die Karte überhaupt erkennt.

      Den dynamischen AppleALC mit Lilu habe ich auch schon ausprobiert ... es funktioniert alles nicht.

      Woran kann das an meinem Kaby Lake Noteboon liegen ? Was kann ich noch machen ? Ich müsste sonst den VoodooHDA nutzen, würde ich aber ungern da es heißt, dass meine Audiokarte wird voll unterstützt!

      Bilder sind ausgeblendet, bitte einloggen oder registrieren.

      Ich weiß derzeit nicht mehr weiter, was ich falsch mache, bzw. wie ich das zum laufen bekomme, damit ich auch was höre.

      Vielen Dank im Voraus!


      Gesendet von iPhone mit Tapatalk
      MSI GP72 7REX Leopard Pro
      • Mainboard: MS-1799
      • CPU: Intel Core i7-7700HQ (8 CPU's @ 2.8 GHz)
      • RAM: 16 GB RAM
      • Grafikkarte: Intel HD Graphics 630 & NVIDIA GeForce GTX 1050 Ti
      • Audio: Realtek HD Audio ALC898
      • WLAN: EDIMAX WLAN-Stick
      Da würde ich andere Audio-Layout-IDs einfach der Reihe nach durchprobieren.
      Ist zwar mühsam, aber...... 8o
      ###

      Das würde ich auch probieren: Original AppleHDA.kext wieder einspielen und dazu einen etwas älteren AppleALC.kext (nimm soeinen, der noch keinen Lilu.kext braucht) im Clover-Ordner /kexts/others reinhauen.

      ###
      Da du auch mit den Beastern am Start bist kann es sein, dass dort noch irgendwelche andere Dinge installiert wurden, welche jetzt ev. hakeln....
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover 4114 10.11.6 GraKa GT710 mit Links sind ausgeblendet, bitte einloggen oder registrieren.
      Clover 4114 10.12.6 GraKa GT710

      Probleme mit Audio - Realtek ALC 889 / 898 (?)

      Vielen Dank für eure Hilfe! Ich habe es endlich geschafft! Ich habe mir den dynamischen AppleHDA Patcher geholt mit Lilu und in Clover FixHDA sowie inject ID 11 gesetzt. Funktioniert bestens.
      MSI GP72 7REX Leopard Pro
      • Mainboard: MS-1799
      • CPU: Intel Core i7-7700HQ (8 CPU's @ 2.8 GHz)
      • RAM: 16 GB RAM
      • Grafikkarte: Intel HD Graphics 630 & NVIDIA GeForce GTX 1050 Ti
      • Audio: Realtek HD Audio ALC898
      • WLAN: EDIMAX WLAN-Stick

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „JeromeM90“ ()

      Nabend zusammen,

      Bin ja seit heute neu hier.
      Ich habe genau das gleiche Problem mit meinem Acer Aspire V3-772G. Habe dort such Sierra installiert und bekomme den Sound nicht in Gang gesetzt.
      Wäre es möglich, das Du mir das mal Schritt für Schritt aufzeigst, wie Du vorgegangen bist??
      Wäre echt super.
      Da ich auch noch Anfänger darin bin, brauche ich etwas Starthilfe.
      Hallo Daniel-dm, erstmal willkommen im Forum. :welcome6:


      Voraussetzung ist, dass du einen ORIGINALEN (nicht gepatchten AppleHDA.kext) kext am Start hast. Dann kopierst du den neuesten AppleALC.kext und den LILU.kext in das Verzeichnis /EFI/CLOVER/kexts/other hinein.
      Dann öffnest du mit dem CloverConfigurator deine config.plist und setzt einen Haken:
      /ACPI FixHDA
      Nun muß noch das richtige AudioLayout Gesetz werden:
      /DEVICES Audio Inject 1
      Diese Ziffern können auch abweichend von 1 sein ( Post 3), da war es z.B. die 11.
      Wie die richtige Ziffer für dein ACER Aspire ist, kann ich dir nicht sagen. Entweder probieren oder Tante Google fragen.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover 4114 10.11.6 GraKa GT710 mit Links sind ausgeblendet, bitte einloggen oder registrieren.
      Clover 4114 10.12.6 GraKa GT710
      Hm, gute Frage!!!
      Der originale Kext ist natürlich immer vorhanden nach einer Neuinstallation, klar.
      Solange man nichts bezüglich Sound installiert hat, z.B. gepatchter AppleHDA.kext oder Voodoo-Zauber,, oder oder oder, kann man davon ausgehen, dass er im Originalzustand vorhanden ist.
      Da du jetzt sicherlich mit der Version 10.12.5 arbeitest, könntest du warten, bis das ComboUpdate 10.12.6. erscheint. Nach diesem Update ist garantiert wieder der Ori-Kext drauf (war zumindest bis jetzt immer).
      Eine andere Möglichkeit wäre auch (aber komplizierter), den OriKext aus dem Installer zu extrahieren und in den Ordner /S/L/E anschließend reinzukopieren.
      :guck: Links sind ausgeblendet, bitte einloggen oder registrieren.
      & VG


      Test-Schlauberger :kaffee2:

      GA H97-HD3, I5-4460, 16GByte RAM
      Clover 4114 10.11.6 GraKa GT710 mit Links sind ausgeblendet, bitte einloggen oder registrieren.
      Clover 4114 10.12.6 GraKa GT710